Kleanse

If you have a question for the CYCO staff then this is the place to ask.
Forum rules
The CYCO forums are for serious discussions on the use of the CYCO Platinum Series of products. We ask you to be mature and to refrain from posting anything that may offend either the users of the forum or CYCO management themselves. This is the official CYCO forums and as such should be treated accordingly, any text, images etc that we deem inappropriate for the CYCO forums will be deleted immediately with possible user bans to follow.
Post Reply
ZombyWoof
Australia
Posts: 3
Joined: Sat Apr 14, 2018 11:03 am

Sun Aug 05, 2018 1:40 pm

When running Kleanse once every 7 -10 days i have to raise pH from 3.5 to 5.8. I thought it strange as everything else is pH balanced when i mix my feed. I put 5 litres with 10 ml kleanse through a 50cm pot or till i see runoff coming out . Feeding @ 1050ppm runoff is 350 ppm . Am i running Kleanse correctly ? Pot size is 51 cm ( 21 gallons ), Coco, feeding Swell, Supa Siky, Bloom A & B. Everything looks really good, except the clones dont seem as big as seed. Just curious if i am correct also when mixing my feed should i mix the Swell then S/Stky then the Bloom A & B ? Any help greatly appreciated.


User avatar
DeeMarie724
United States of America
Posts: 65
Joined: Wed Jun 22, 2016 11:52 am
Location: California

Wed Aug 08, 2018 5:47 am

Hi there!

As far as pH adjusting, Kleanse will lower the pH a little more in RO water. It makes it on the acidic side so It’s not uncommon to have to adjust PH when using Kleanse, so your not doing anything incorrect there. You can mix bases Supa and swell in any given order as well. Hope this helps, let’s s know if you have any other questions, and have a great day!
D Marie~
Post Reply